Quantcast

Bad or Missing Command Interpreter, help!

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Bad or Missing Command Interpreter, help!

dashky
Hi everyone! This is my first time using FreeDOS and it's been cool so far. Until I encounter a problem now.

I've tested FreeDOS on a few desktops and laptops, some are ok, but some are not. Those that are not ok will prompt out... the message below when loading the kernel and trying to load the config.sys I think.

Bad or missing Command Interpreter
Enter the full shell command line:
command.com /P /E:256


I've tried to enter the command shell=c:\command.com /p /e:256 into the config.sys but no luck.

One funny thing is, the affected laptop/desktop will be able to load everything (config.sys and autoexec.bat) when I plug in a USB floppy drive. When I unplug it, restart, the same problem persists. :D

This is a problem because it not possible for me to plug-in the usb floppy drive onto the laptop all the time when I start FreeDOS.

This happen to those affected desktops too. When I disable floppy support, the same problem as above. But when I enable floppy support, it works!

So, is there anyway around this problem? Is it possible to trick FreeDOS that I have a floppy drive connected even when I don't have one?

Appreciate it if someone can lend me a helping hand or advice.

Thank you very much and have a nice day! :)

Loading...