kernel 2042 fdconfig.sys install param not passing switches to command

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

kernel 2042 fdconfig.sys install param not passing switches to command

Nando Eva
Hi,

I noticed was getting more messages appearing during my bootup with kernel 2042 compared to 2041. Upon investigation, I found it is not passing any switches given in fdconfig.sys install=<command> <swiches> to the command. This is the case also of installhigh.

eg fdconfig.sys lines:

2345?install=\DOS\ansi.com /q
6?install=\core\tm.exe /43

Confirmed behaviour under kernel 2041
* ansi.com quietly loads as directed (/q)
* tm.exe (inkutils) switches to 80x43 mode as directed (/43)

Confirmed behaviour under 2042
* ansi.com ignores /q and prints usage messages
* tm.exe does not switch to 80x43 mode, instead reports current mode consistent as if no switch given.

This and the NUL drive/dir bug I reported several days ago, with a hotfix kernel provide by Tom,  are pretty big bugs. For now I've gone back to 2041 as am concerned about other nasties I've yet to discover. 

Nando


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Freedos-kernel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/freedos-kernel